Sign up to see a live demo!Request a Demo »

Skillsoft, the provider of the Business Skills Bundle of courses licensed through CU Training, is updating their browser requirements, effective June 1, 2018. After this date, CU Training Learning Partners who use older versions of the Microsoft Internet Explorer browser may have difficulty accessing this content. This change will not affect any CU Training-developed courses and exams.

This browser update affects Internet Explorer versions 8, 9, and 10, because these versions do not support the TLS 1.2 communications security protocol. If you use a browser that doesn’t support TLS 1.2, an error message will appear and the course will not start. Note that the Windows XP operating system is also not able to access these courses.

  • Microsoft Edge v14+ (Windows 10 only)
  • Microsoft Internet Explorer 11 (Windows 7, 8.1, 10)
  • Google Chrome v63+ (Windows 7, 8.1, 10)
  • Mozilla Firefox v52+ (Windows 7, 8.1, 10)
  • Apple Safari v10.1+ (macOS only)

If you would like more information about this update, please click here for the FAQ from Skillsoft.

If you have any questions about these changes, please contact support@cutraining.com.

 

Spread the word. Share this post!